where to get pots for my Lakland 55 02

Amps, Cabs, Effects, Pickups, Onboard Preamps
Post Reply
User avatar
billybass
Posts: 380
Joined: 05 Sep 2011, 07:32
Location: NSW

where to get pots for my Lakland 55 02

Post by billybass » 02 May 2013, 07:45

Hi All in Bassland,
I recently purchased a second hand Lakland deluxe skyline 55 02 bass.
The guy who owned it before did not look after it.
It had rusty strings and the adjustment screws were rusted and frozen.
I managed to clean up the screws with some WD40 and some working and that's not the problem.
The bass pot is stuffed, I tried to clean it out with WD40, that did not work, then I used some electronic cleaner and that did not work either.
When you turn the bass pot the guitar goes off, no output signal. I opened up the control cavity and the pots are nothing I've ever seen before. Stamped on them is B50 ohm, they have a centre dent so you know where 0 is on the pot.
I open up the pot, unclamped the claws that hold it together and there was no copper or metal where the sweep would be. I have emailed Lakland in Chicago, but have not heard from them.
Any suggestions on how to fix this?
Cheers Billy

User avatar
petersemple
Posts: 1006
Joined: 15 Oct 2012, 08:51

Re: where to get pots for my Lakland 55 02

Post by petersemple » 02 May 2013, 08:09

From memory STewmac carry pots in weird values with centre detents. You would probably also find it on ebay. The B indicates linear, so you are looking for a 50 ohm linear pot with a centre detent
Basses: Wasburn Status 4, Fretless 4 made from parts, Fretted through neck 5 made by me
Amp: Eminar bass 400 into home made cab with JBL 15"

User avatar
rudager
Posts: 780
Joined: 01 Feb 2011, 12:32
Location: Brisbane

Re: where to get pots for my Lakland 55 02

Post by rudager » 02 May 2013, 08:17

Which preamp is in it? The Lakland or Bartolini one?

User avatar
TheMachineIdol
Posts: 463
Joined: 29 Nov 2011, 21:38
Location: Bathurst, NSW

Re: where to get pots for my Lakland 55 02

Post by TheMachineIdol » 02 May 2013, 11:13

I have the same B50 pots in my 55-02, which has the Bart pre and pups, so I'm going to assume its this combination.

Although I'm not sure what value the Hanson pre has in its pots..

User avatar
petersemple
Posts: 1006
Joined: 15 Oct 2012, 08:51

Re: where to get pots for my Lakland 55 02

Post by petersemple » 02 May 2013, 11:36

According to the Bart site, the pots for their preamps are 50K, not 50 ohm. They would usually be marked B503, not B50. 50K would certainly be easier to find than 50 ohm.
Basses: Wasburn Status 4, Fretless 4 made from parts, Fretted through neck 5 made by me
Amp: Eminar bass 400 into home made cab with JBL 15"

User avatar
PilbaraBass
Posts: 15026
Joined: 23 Oct 2008, 17:07
Location: Gladstone, QLD

Re: where to get pots for my Lakland 55 02

Post by PilbaraBass » 02 May 2013, 11:58

I SERIOUSLY doubt that the pot is a 50 ohm pot. It's most-likely a 50k linear trip...

you have another of these pots that works right? measure the resistance between the outside lugs....

centre detente may be quite hard to find on a pot that's not a blend pot...

have a look through here http://www.banzaimusic.com/Potentiometers/

and see which one fits the job... and then try to source it locally (or buy it from them )
'98 Carvin AC40, '07 Squier JDAV, '91 P-bass, '96 Ibanez ATK300F, '15 Ibanez SR605
Kanye West wrote:My greatest pain in life is that I will never be able to see myself perform live.

User avatar
billybass
Posts: 380
Joined: 05 Sep 2011, 07:32
Location: NSW

Re: where to get pots for my Lakland 55 02

Post by billybass » 03 May 2013, 00:32

Hi All,
The preamp is a Bartolini and as you all said the mini pot is B50K, my mistake, I will try to find it at banzaimusic thanks everyone for your help.
Cheers Billy

User avatar
ScottyBoy
Posts: 508
Joined: 04 Nov 2008, 21:37
Location: Utah, USA (Brisbane boy!)

Re: where to get pots for my Lakland 55 02

Post by ScottyBoy » 03 May 2013, 05:38

Sorry to hijack - Once I purchased a used 55-01 , the volume pot was dodgy . I emailed Lakland directly asking what pot I should buy. Dan Lakin replied back himself and asked for my address. 5 days later the pot arrived at my Brisbane address free of charge. Hows that for customer service? :)

At any rate, if you are having problem finding the pot, email Lakland themselves. Don't know what their Customer service is like these days.

User avatar
rudager
Posts: 780
Joined: 01 Feb 2011, 12:32
Location: Brisbane

Re: where to get pots for my Lakland 55 02

Post by rudager » 03 May 2013, 11:19

If you get stuck I have a couple of those B50s from an old Bart MK1 pre that I pulled out of my 55-01 you can have.

User avatar
billybass
Posts: 380
Joined: 05 Sep 2011, 07:32
Location: NSW

Re: where to get pots for my Lakland 55 02

Post by billybass » 04 May 2013, 10:35

PM'ed rudager to take up his generous offer,
Cheers Billy

User avatar
billybass
Posts: 380
Joined: 05 Sep 2011, 07:32
Location: NSW

Re: where to get pots for my Lakland 55 02

Post by billybass » 05 Jun 2013, 00:48

Hi I'm back and my problem with the bass pot still not solved. I got a replacement from rudager, a generous ozbasser, but the shaft was the wrong kind, solid rather than splined.
Lakland sent me a brand new replacement and the problem is still there. When I turn the bass boost 1/4 turn, signal cuts out. If it's the preamp I have no idea what I need to do. Cheers Billy

User avatar
maxgroover
Posts: 3427
Joined: 19 May 2009, 11:28
Location: Sydney

Re: where to get pots for my Lakland 55 02

Post by maxgroover » 05 Jun 2013, 10:40

billybass

I reckon take it to Matt at Saltmine Repairs (info@saltminerepair). It could be just a wiring problem that needs sorting. He should be able to pinpoint the problem once he gets to look under the hood.
Ozbass moderator

The Moods Band

Mailloux, Fender, Lakland, Musicman, Univox basses
Genz Benz, BBE, Crown, Zoom amps and preamps
Bergantino & Genz Benz Cabs

User avatar
billybass
Posts: 380
Joined: 05 Sep 2011, 07:32
Location: NSW

Re: where to get pots for my Lakland 55 02

Post by billybass » 25 Aug 2013, 22:38

I finally took my bass to Jeff Mallia to have a look.
He checked the wiring and said the preamp was faulty and not the pot.
I was also having problems with the battery going flat after minimal use, like after 14 hours of playing, so I had him put in a new Aguilar OBP 3, and she's back in business.
It sounds different. When it is set to flat, it really is flat. The mids controll on this preamp is very effective, really cuts through when you boost, push pull 400 or 800 mids.
I have checked the web and other bass players have had similar problems with the Bart preamp on their Lakland Skyline 55 02 as well.
One guy in the US said he lost all the bottom end one night at a gig.
Just thought I'd share in case any one else may encounter similar problems.
Cheers Billy

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests